Resolved
This incident has been resolved
Monitoring
Situation is stable now, all functionalities are back up. We keep monitoring the situation
Identified
The root cause of the problem has been identified. Our Admin's team is in the process of mitigating and fixing the issue
Investigating
Access and usage of the Agent Application is impaired at the moment. We're currently investigating the issue