Some transcripts emails not delivered

Incident Report for LiveChat

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 21:47 CET

Investigating

We are currently investigating this issue.
Posted Feb 10, 2025 - 18:32 CET
This incident affected: LiveChat (Subprocessors' service).